Pomoc do modułu iMeteo

PROEKO Ryszard Samoć

62-800 Kalisz, ul. Biernackiego 8
tel. 62 757 39 87
E-mail: ryszard@samoc.net, biuro@proeko-rs.pl
www.proeko-rs.pl

Program "iMeteo"

Program służy do pobierania publicznie dostępnych danych obserwacji meteorologicznych z serwerów IMGW oraz wykorzystania ich m.in. do tworzenia róż wiatrów.

W Internecie dostępne są dane od lat sześćdziesiątych (lista danych).
Program zawiera bazę stacji meteorologicznych, w tym informacje o współrzędnych geograficznych oraz dla niektórych stacji- wysokość anemometru.
Przed utworzeniem róży wiatrów należy pobrać pliki dla wybranej stacji klikając przycisk "Pobierz dane meteo".
Następnie należy kliknąć przycisk "Utwórz różę wiatrów".

Program może utworzyć róże zawierające uśrednione liczby obserwacji dla całego okresu, w którym dostępne są dane, a także róże dla sezonu grzewczego i poza sezonem grzewczym (letniego) oraz róże dla dnia i nocy.
Program uwzględnia poprawkę na różną częstotliwość obserwacji w poszczególnych latach np. dla Helu do 1993 r co 3 godziny, potem co godzinę.

Klikając przycisk "Info" można zobaczyć, które pliki zostały pobrane i ewentualnie jakich jeszcze brakuje.

Oprócz tworzenia róż wiatrów program umożliwia zebranie niektórych danych statystycznych przydatnych w pakiecie Operat. Są to liczba dni z opadami deszczu i śniegu oraz maksymalna prędkość wiatru w porywach.

Zobacz: Sposób obliczania klas równowagi atmosfery


Główne okno programu "iMeteo"

Przed utworzeniem róży wiatrów należy pobrać pliki dla wybranej stacji klikając przycisk "Pobierz dane meteo".
W celu utworzenia róży wiatrów należy kliknąć przycisk "Utwórz różę wiatrów".

Klikając przycisk "Info" można zobaczyć, które pliki zostały pobrane i ewentualnie jakich jeszcze brakuje.

Przycisk "Szukaj najbliższej stacji" służy do wyszukiwania najbliższej stacji meteorologicznej od podanej lokalizacji na podstawie danych róż wiatrów zawartych w bazie programu.

Oprócz tworzenia róż wiatrów program umożliwia zebranie niektórych danych statystycznych przydatnych w pakiecie Operat.
Są to liczba dni z opadami deszczu, maksymalna prędkość wiatru w porywach oraz wykresy wieloletnie.
W menu dostępne są następujące komendy:

Dane:
Analiza Wyświetla listę pobranych plików dla poszczególnych stacji meteorologicznych.
Narzędzia:
Wschód / zachód słońca | Po wyborze stacji meteorologicznej oraz daty program pokazuje godzinę wschodu i zachodu słońca.
Intensywność promieniowania słonecznego | Po wyborze stacji meteorologicznej oraz daty program pokazuje Ic (intensywność promieniowania słonecznego) dla danej godziny. Program może również uwzględnić zachmurzenie.
Zapis obserwacji dobowych do xls | Umożliwia zapis pliku zawierającego wyniki obserwacji z jednej doby z wyliczonym natężeniem promieniowania słonecznego oraz klasami równowagi atmosfery dla poszczególnych obserwacji. Po wyborze stacji meteorologicznej i daty należy kliknąć przycisk "Zapisz" oraz wybrać katalog, w którym plik ma być zapisany.
Opcje:
Opcje obliczeń | Umożliwia zmianę sposobu ustalania klasy równowagi atmosfery.
Stacje meteorologiczne | Opcja zaawansowana. Otwiera plik Excela, w którym można dodać stacje z kodami i kompletnymi współrzędnymi.
Katalog danych | Umożliwia zlokalizowanie oraz zmianę katalogu, z którego odczytywane są pliki.

Zobacz:
Opis programu
Sposób obliczania klas równowagi atmosfery

Program zamykamy przyciskiem "Zamknij".


Pobieranie danych

Moduł iMeteo służy do pobierania publicznie dostępnych danych obserwacji meteorologicznych z serwerów IMGW.
W Internecie dostępne są dane dla kilkudziesięciu lat.

Przycisk "Pobierz dane meteo" otwiera okno "Pobieranie plików z serwera imgw.pl".
Należy wybrać odpowiednią stację meteorologiczną z rozwijalnej listy.
Wyboru można też dokonać wpisując początek nazwy. Obok pokaże się kod stacji.

Użytkownik może określić zakres pobieranych danych wybierając początkowy i końcowy rok, dla którego program pobiera pliki.
Dostępne są również opcje "Tylko brakujące pliki" i "Zatrzymaj gdy brak pliku".

Można zmienić katalog, do którego zapisywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu.

W celu pobrania danych należy kliknąć przycisk "Pobierz". Można przerwać pobieranie danych przyciskiem "Przerwij".

Z Internetu pobierane są pliki spakowane o rozszerzeniu zip. Następnie program je rozpakowuje do plików o rozszerzeniu csv.

Po zakończeniu pobierania danych dla wszystkich potrzebnych stacji meteorologicznych należy kliknąć przycisk "Zamknij".


Tworzenie róży wiatrów

W celu utworzenia nowej róży wiatrów należy kliknąć przycisk "Utwórz różę wiatrów" i wybrać stację meteorologiczną, przy czym program wyświetli tylko te stacje, dla których już zostały pobrane dane (Zobacz: Pobieranie danych). Wyboru można też dokonać wpisując początek nazwy stacji.
Można zmienić katalog, z którego odczytywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu.

Następnie należy wybrać zakres lat, dla których mają być uśrednione wyniki obserwacji lub zaznaczyć opcję "Wszystkie lata".

Dla niektórych stacji brak jest informacji o wysokości anemometru. W takim przypadku użytkownik może sam wpisać wysokość anemometru lub program przyjmie domyślnie wysokość 14 metrów.

Program może utworzyć różę zawierającą uśrednione liczby obserwacji dla wybranego okresu, a także róże dla sezonu grzewczego i poza sezonem grzewczym (letniego) oraz róże dla dnia i nocy. W celu utworzenia tych róż zaznaczamy opcję "Dodatkowe róże dla sezonu grzewczego/letniego" lub "dnia/nocy".
Po kliknięciu przycisku okres otworzy się okno, w którym można zdefiniować inny sezon grzewczy niż domyślny.

Po naciśnięciu przycisku " [image] Odczytaj dane i oblicz stany równowagi" program utworzy różę/róże wiatrów dla wybranej stacji meteorologicznej.

Szczegółowe wyniki obserwacji, które posłużyły do zbudowania róży można wyeksportować w formie pliku w Excelu po kliknięciu przycisku "Szczegóły".
Po naciśnięciu przycisku " [image] Raport" wyświetla się udział procentowy obserwacji meteorologicznych z podziałem na prędkości wiatru, stany równowagi atmosfery i kierunki wiatru, który również można zapisać, skopiować do schowka lub wydrukować.

Utworzone róże można zapisać przyciskiem "Zapisz" po podaniu ich nazwy.

Okno zamykamy przyciskiem "Zamknij".

Informacja: w menu "Narzędzia" można zapisać wyniki obserwacji z jednej doby z wyliczonym natężeniem promieniowania słonecznego oraz klasami równowagi atmosfery dla poszczególnych obserwacji po wybraniu polecenia "Zapisz obserwacje dobowe".


Algorytm klas

Metodyka wyznaczania stanów równowagi atmosfery zastosowana w programie "iMeteo"

Wyznaczenie stanów równowagi atmosfery (klas stabilności) obejmuje następujące etapy:

I. Wyznaczenie intensywności promieniowania Słońca przy powierzchni ziemi po uwzględnieniu stopnia zachmurzenia nieba

Natężenie promieniowania słonecznego docierającego do górnych granic atmosfery określone jest przez stałą słoneczną. Wielkość ta jest zdefiniowana dla średniej odległości Ziemia-Słońce i wynosi około 1366,1 W/m2. Natężenie promieniowania słonecznego zmienia się w cyklu rocznym ze względu na zmiany odległości pomiędzy Ziemią a Słońcem w zakresie ±3,4%. Ponadto natężenie zależy od kąta padania promieni zależnego od współrzędnych geograficznych, pory dnia i pory roku .

Natężenie promieniowania może być obliczane dwiema metodami :

1. Metoda IMGW :
wzór na intensywność promieniowania

gdzie:
Ic - intensywność promieniowania Słońca po uwzględnieniu wpływu zachmurzenia ,
Hs,i - godzina, dla której jest wyznaczana intensywność promieniowania słonecznego
Hs,c - godzina kulminacji Słońca w określonym położeniu ,
Dy - numer dnia w ciągu roku,
kcl - współczynnik korekcyjny uwzględniający wpływ zachmurzenia.

Wartości współczynnika korekcyjnego kc (cl) w zależności od stopnia zachmurzenia.

zachmurzenie[oktany] | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
kc (cl ) | 1,1 | 0,9 | 0,8 | 0,76 | 0,705 | 0,655 | 0,57 | 0,455 | 0,2

2. Przy wykorzystaniu formuł zawartych w arkuszu kalkulacyjnym dostępnym na stronie California Polytechnic State University : https://www.calpoly.edu/~gthorncr/documents/solaranglecalcs.xls
wzory te uwzględniają szerokość geograficzną wybranej miejscowości.

II. Określenie stanu równowagi w zależności od wyznaczonej wcześniej intensywności
promieniowania i prędkości wiatru

W programie dostępne są dwie metody:

1.Metoda IMGW - ze wzorów

w nocy:
noc

w dzień
wzór dzień
gdzie:
l - wielkość pomocnicza,
k1, k2, k 3, k4 - wartości stałe zależne od prędkości wiatru.

u | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
k1 | 32,25 | 23,5 | 17,2 | 5,3 | 2,52 | 0,319 | 0,161 | 0 | 0
k2 | 1,31 | 0,882 | 0,588 | 0,0355 | -0,0609 | -0,0845 | -0,0249 | -0,0225 | -0,00625
k3 | 3,275 | 2,92 | 2,73 | 2,265 | 2,06 | 1,155 | 0,274 | 0,153 | 0
k4 | 0,00462 | 0,00585 | 0,00606 | 0,0071 | 0,00442 | 0,0095 | 0,0129 | 0,0107 | 0,00792

Następnie klasy są obliczane z tabeli:
stan równowagi atmosfery | stan równowagi atmosfery | Wartość pomocnicza l
A | 1 | 0 <= l <1
B | 2 | 1 <= l <2
C | 3 | 2 <= l <3
D | 4 | 3 <= l <4
E | 5 | 4 <= l <5
F | 6 | l >= 5

2. Zmodyfikowana metoda Pasquille’a

Zależność klasy równowagi od prędkości wiatru, intensywności promieniowa i zachmurzenia przedstawia się następująco:

Dzień
Prędkość wiatru na wysokości 10 m n.pt. m/s | Natężenie promieniowania słonecznego W/m2
 | Silne ( > 600) | Umiarkowane (>=300 <=600) | Niewielkie < 300 | Zachmurzenie całkowite
<2 | A | A– B | B | C
2 – 3 | A – B | B | C | C
3 – 5 | B | B – C | C | C
5 – 6 | C | C – D | D | D
>6 | C | D | D | D

Noc

Prędkość wiatru na wysokości 10m n.pt. m/s | Godzina w trakcie wschodu lub zachodu słońca | Stopień zachmurzenia nieba ( oktany)
 |  | 0-3 | 4-7 | Zachmurzenie całkowite (8)
< 2 | D | F | F | D
2 – 3 | D | F | E | D
3 – 5 | D | E | D | D
5– 6 | D | D | D | D
>6 | D | D | D | D

W przypadku klas pośrednich (np. B-C) liczebność klas należy podzielić proporcjonalnie do obu przypadków (czyli 50% do klasy B i 50% do klasy C).
Prędkość wiatru jest przeliczana ze wzoru:
uh =ua*(h/ha)m

gdzie:
ua- prędkość wiatru na wysokości anemometru, m/s
h – wysokość , dla której jest obliczana prędkość wiatru, m
uh- prędkość na określonej wysokości – h
m – wykładnik meteorologiczny zależny od klasy równowagi

Przykład obliczenia metodą IMGW
 Przykład obliczenia metodą Pasquille'a:
Współrzędne geograficzne: długość g. 18,0819, szerokość 52,766
Data: 2017-05-01
Godzina Hs,i : 13:00
Czas kulminacji słońca: 12:44 (Hs,c= 12,733 )

Zachmurzenie: 3 oktany

kc = 0,76
Ic= 793,2 W/m2
Wysokość anemometru 14 m.
Prędkość wiatru na wysokości 14 m 7,7 m/s, po przeliczeniu na 10 m 7,2 m/s

k1 | 0
k2 | -0,0225
k3 | 0,153
k4 | 0,0107

l = 2,607
Klasa : C (3)
Współrzędne geograficzne: długość g. 18,0819, szerokość 52,766
Data: 2017-05-01
Godzina: 13:00
Wysokość anemometru 14 m.
Prędkość wiatru na wysokości 14 m 7,7 m/s, po przeliczeniu na 10 m 7,2 m/s
Zachmurzenie: 3
Obliczone natężenie promieniowania słonecznego : 1074 W/m2,
po uwzględnieniu zachmurzenia 742 W/m2
Klasa odczytana z tabeli: C (3)


Wykresy wieloletnie

W celu utworzenia wykresów wieloletnich należy wybrać stację meteorologiczną, przy czym program wyświetli tylko te stacje, dla których już zostały pobrane dane (Zobacz: Pobieranie danych).
Wyboru można też dokonać wpisując początek nazwy stacji. Obok pokaże się kod stacji.
Można zmienić katalog, z którego odczytywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu.

Użytkownik może wybierać początkowy i końcowy rok, dla którego program wyszukuje dni z opadami lub zaznaczyć opcję "Wszystkie lata".

Następnie należy kliknąć przycisk " [image] Analizuj".
Program wyświetli wykresy wieloletnie dla wybranych lat.

Wykresy można skopiować do schowka przyciskiem " [image] Kopiuj" oraz zapisać przyciskiem "Zapisz" po podaniu nazwy pliku.

Po naciśnięciu przycisku " [image] Zestawienie" wyświetla się raport ze średnimi z obserwacji wieloletnich, który również można skopiować do schowka, zapisać lub wydrukować.

Pod prawym przyciskiem myszy znajduje się menu zawierające następujące opcje:
  • Ustawienie drukarki
  • Marginesy
  • Komenda "Numeracja stron"

Okno zamykamy przyciskiem "Zamknij".


Porywy wiatru

Wyszukiwanie prędkości wiatru w porywach

W celu wyszukania prędkości maksymalnej wiatru należy wybrać stację meteorologiczną, przy czym program wyświetli tylko te stacje, dla których już zostały pobrane dane (Zobacz: Pobieranie danych).
Wyboru można też dokonać wpisując początek nazwy stacji. Obok pokaże się kod stacji.
Można zmienić katalog, z którego odczytywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu.

Użytkownik może wybierać początkowy i końcowy rok, dla którego program wyszukuje prędkość wiatru w porywach lub zaznaczyć opcję "Wszystkie lata".

Następnie należy kliknąć przycisk " [image] Analizuj".
Program wyświetli maksymalną wartość prędkości wiatru ze wszystkich pomiarów dla każdego wybranego roku.

Wyniki można skopiować do schowka przyciskiem kopiuj.

Okno zamykamy przyciskiem "Zamknij".


Dni z opadami

Dni z opadami deszczu i śniegu

W celu obliczenia liczby dni z opadami deszczu i śniegu należy wybrać stację meteorologiczną, przy czym program wyświetli tylko te stacje, dla których już zostały pobrane dane (Zobacz: Pobieranie danych). Obok pokaże się kod stacji.
Można zmienić katalog, z którego odczytywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu.

Użytkownik może wybierać początkowy i końcowy rok, dla którego program wyszukuje dni z opadami lub zaznaczyć opcję "Wszystkie lata".
Można zmienić wartość opadu w milimetrach słupa wody, od której program klasyfikuje dany dzień jako z opadem. Domyślnie przyjęte jest 0,254 mm.

Następnie należy kliknąć przycisk " [image] Analizuj".
Program wyświetli ilość dni z opadem dla każdego wybranego roku oraz średni udział dni z opadem dla wybranych lat.

Wyniki można skopiować do schowka przyciskiem kopiuj.
Po naciśnięciu przycisku " [image] Szczegóły" wyświetla się raport z liczbą dni z opadem w poszczególnych miesiącach, który również można skopiować do schowka, zapisać lub wydrukować.

Okno zamykamy przyciskiem "Zamknij".


Opcje

Opcje obliczeń

W tym oknie można zmienić sposób ustalania klasy równowagi atmosfery.

Sposób określania klasy równowagi atmosfery:
  1. Ze wzorów empirycznych (metoda IMGW)
  2. Z tabel (metoda Pasquilla) - klasy są odczytywane z tabel dla stopnia zachmurzenia ( w nocy), natężenia promieniowania słonecznego (w dzień) i prędkości wiatru
Domyślną metodą jest metoda 1.

Sposób obliczania promieniowania słonecznego:
  1. Z różnicy czasu od południa (metoda IMGW) - natężenie promieniowania jest funkcją różnicy czasu do południa
  2. Z kąta padania promieni - stosowana jest metoda dokładna, uwzględniająca szerokość geograficzną miejscowości.
Domyślną metodą jest metoda 1.

Więcej w opisie algorytmów obliczeń


Analiza danych

Analiza danych w pobranych plikach

Po kliknięciu przycisku " [image] Analizuj" program wyświetli listę już pobranych plików dla poszczególnych stacji meteorologicznych (Zobacz: Pobieranie danych).

Można zmienić katalog, z którego odczytywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu .

Po kliknięciu przycisku "Dane w Internecie" program przeanalizuje dostępność plików dla poszczególnych stacji meteorologicznych dla lat 1960 - 2018. Zestawienie można skopiować do schowka, zapisać lub wydrukować. Można przerwać analizę danych przyciskiem "Przerwij".

Przykładowe zestawienie jest też dostępne pod adresem: lista danych.

Okno zamykamy przyciskiem "Zamknij".


Szukaj najbliższej stacji meteorologicznej w bazie róż wiatrów

Szukaj najbliższej stacji meteorologicznej na liście stacji meteorologicznych

Okno służy do wyszukiwania najbliższej stacji meteorologicznej na liście stacji meteorologicznych (zawartej w pliku stacje_meteo.xls).

Znajdowana jest stacja pomiarowa najbliższa w linii prostej od punktu, dla którego podano współrzędne geograficzne.
Współrzędne można wpisać ręcznie lub pobrać dla:

Miejscowości | Należy kliknąć przycisk "Znajdź miejscowość" oraz wpisać nazwę miejscowości lub adres (lub tylko ulicę) zakładu. Po kliknięciu przycisku "Szukaj" program wyświetli listę lokalizacji spełniających te kryteria. Należy zaznaczyć na liście szukaną lokalizację i kliknąć przycisk „OK”. Wtedy program przeniesie jej współrzędne do okna wyszukiwania najbliższej stacji meteorologicznej.
Z mapy | Należy kliknąć przycisk "Pobierz z mapy" oraz wpisać nazwę miejscowości lub adres (lub tylko ulicę) zakładu. Po kliknięciu przycisku "Szukaj" program wyświetli listę lokalizacji spełniających te kryteria. Należy zaznaczyć na liście szukaną lokalizację i kliknąć przycisk „Wybierz”. Program otworzy mapę Google z ustawionym środkiem mapy na współrzędne geograficzne dla wybranej lokalizacji. Mapę można przesuwać przez przeciąganie myszą. Na mapie można zaznaczyć punkt (inny niż środek mapy) poprzez kliknięcie lewym klawiszem myszy przy wciśniętym klawiszu Ctrl. Wtedy zostaną wyświetlone informacje o współrzędnych geograficznych zaznaczonego punktu. W przypadku, gdy na mapie nie zaznaczono żadnego punktu, po kliknięciu przycisku „OK”program przeniesie współrzędne środka mapy.

Kliknięcie przycisku " [image] Szukaj stacji" spowoduje wyszukanie najbliższej stacji meteorologicznej i wyświetlenie informacji o niej.
Okno zamykamy przyciskiem "Zamknij".


Obliczanie średniej temperatury w miesiącach

Obliczanie średniej temperatury, zmienności temperatur i wilgotności w miesiącach

Średnie temperatury są potrzebne do obliczania emisji zimnej w module "Samochody".
Zmienność dobowa temperatury (diurnal temperature variation) jest stosowana do obliczania emisji pochodzącej ze strat w oddychaniu przez otwór odpowietrzający zbiornika paliwa wg. metodyki EMEP/EEA.
Wilgotność ma wpływ na pracę klimatyzacji.

Najpierw należy wybrać stację meteorologiczną, przy czym program wyświetli tylko te stacje, dla których już zostały pobrane dane (Zobacz: Pobieranie danych).
Wyboru można też dokonać wpisując początek nazwy stacji. Obok pokaże się kod stacji.

Można zmienić katalog, z którego odczytywane są pliki po kliknięciu przycisku zmień katalog i wyborze nowego katalogu.

Użytkownik może wybrać początkowy i końcowy rok analizy, wstępnie ustawiono 10 ostatnich lat.

Następnie należy kliknąć przycisk " [image] Analizuj".

Program wyświetli raport zawierający wyniki obliczeń z podziałem na miesiące.
Wyniki można skopiować do schowka przyciskiem kopiuj.

Można je również dodać do wcześniej utworzonej róży wiatrów przyciskiem "Dodaj do róży" i wybraniu odpowiedniej róży. Wtedy wyniki będą widoczne dla modułu "Samochody".

Okno zamykamy przyciskiem "Zamknij".