Pomoc do modułu iMap

PROEKO Ryszard Samoć

62-800 Kalisz, ul. Biernackiego 8
tel. 62 757 39 87
E-mail: rs@proekors.pl, biuro@proekors.pl
www.proekors.pl

Moduł IMap

Moduł służy do pobierania map z serwerów internetowych do wykorzystania w pakiecie „Operat” jako mapy do wyboru współrzędnych lub mapy do wykresu izolinii.

Dostępne są trzy wersje modułu:

  1. moduł korzystający z serwisu Google Maps przez wbudowany w Windows Internet Explorer. Wymagany jest Internet Explorer w wersji 11.0 . Obecnie opcja ta jest niezalecana ze względu na wycofanie się Google Maps z obsługi I.E.
  2. moduł EC (interface opr. Christopher Escot-Sep) korzystający z map Bing, Here , Open Street Map, Open Topo Map i Yandex. Uwaga: mapy Bing i Yandex posiadają ograniczenia licencyjne.
  3. moduł korzystający z serwisu Google Maps i Microsoft Edge Chrome.
Mapy Google są mapami komercyjnymi, ale umożliwiają publiczne prezentowanie treści w internecie, filmach i materiałach drukowanych z podaniem źródła danych.
Pakiet "Operat FB" posiada zarejestrowane klucze (ApiKey): Google Maps , Here , Bing i Yandex

Rodzaj modułu można zmienić w pakiecie "Operat FB" w menu „Opcje/Moduł Imap”.

Przed otwarciem mapy należy wybrać lokalizację używając wyszukiwarki. Wyszukiwać można miejscowości, przy czym program korzysta z nieodpłatnego serwera Geonames (http://www.geonames.org/) lub można wyszukiwać adres wpisując np. miasto, ulicę i numer. W tym przypadku program będzie korzystał z komercyjnej wyszukiwarki Geocodes Google (http://maps.googleapis.com). Komercyjna wyszukiwarka pozwala na nieodpłatne wyszukiwanie do 2500 zapytań dziennie.

Po wpisaniu nazwy miejscowości lub adresu program wyświetli listę lokalizacji spełniających te wyszukiwania, będą one ułożone w kolejności od najlepiej pasującej do kryterium wyszukiwania. Obok lokalizacji będzie podane przyporządkowanie do podziału administracyjnego kraju.

Uwaga! W niektórych przypadkach Geonames nie podaje pełnej informacji o podziale administracyjnym.

Po wybraniu lokalizacji i kliknięciu przycisku „Wybierz” program otworzy mapę Google z ustawionym środkiem mapy na współrzędne geograficzne dla wybranej lokalizacji. Widoczny jest okrąg o promieniu 50*hmax (wysokości najwyższego emitora).

Środek okręgu można przesunąć na żądany emitor poprzez wciśnięcie klawisza F10 i kliknięcie myszą (uwaga: czasem potrzebne jest wielokrotne kliknięcie). Można też zdefiniować inny klawisz niż F10 (przycisk "Fn").
W czasie przesuwania myszy klawisze myszy nie powinny być wciśnięte.

Okrąg ten pozwala zorientować się w rozmiarze potrzebnej mapy do obliczania szorstkości terenu. W oknie do obliczania szorstkości terenu okrąg będzie wykreślony na podstawie współrzędnych najwyższego emitora - może więc wystąpić niewielka różnica.

Mapę można przesuwać przez przeciąganie myszą.

Po załadowaniu mapy zostanie wyświetlona informacja o skali mapy, mnożniku liczby pikseli na metr oraz będą dostępne przyciski i opcje znajdujące się w prawym panelu.

Znaczenie poszczególnych przycisków.
Przycisk | Znaczenie
Ok. (wybierz) | powoduje skopiowanie wybranej mapy do pakietu „Operat”. Mapa zostanie zapisana w bazie danych.
Zapisz do pliku | umożliwia eksport mapy do pliku graficznego w formacie jpeg , png i bmp
+ - | umożliwia zmianę skali mapy
Rodzaj mapy (moduł "Google Maps") | opcja "mieszana" oznacza nałożone mapy satelitarne i drogową. Ponadto dostępne są osobno mapy drogowa, satelitarna i mapa terenu.
Serwer map (moduł EC) | zmienia serwer dostarczający mapy
Powiększenie bitmapy | służy do poprawy jakości wydruku pod wykresem izolinii. Zaleca się korzystanie z map o większej rozdzielczości, którą uzyskuje się przez zwiększenie skali mapy oraz powiększenie rozmiaru mapy kilkukrotnie. U dołu pod opcją znajduje się informacja jaki będzie rozmiar bitmapy w pikselach. Uwaga! w przypadku powiększenia bitmapy innej niż 1 środek mapy nie będzie umieszczony w środku okna. powiększenie
Mapy WMS | otwiera okno do pobierania map z serwerów WMS, w oknie zostaną wpisane współrzędne takie same jak mapy Google.
Okrąg 50 h | rysuje okrąg o promieniu 50 wysokości najwyższego emitora. Jeśli lista emitorów nie została jeszcze wypełniona to wysokość emitora (h) można wpisać ręcznie. Domyślnie środkiem okręgu jest miejsce zaznaczone krzyżykiem. Jeśli nie określono geograficznego początku układu to środkiem jest środek mapy. Środek okręgu można zmienić ręcznie naciskając F10 i klikając myszą (dotyczy modułu na Edge Chrome) Przycisk "Fn" umozlwia zmian e klawisza do zatwierdzania nowego środka okręgu na np "F"

Opcje dostępne przy wyborze mapy do odczytu współrzędnych:
początek układu współrzędnych geograficznych można zmienić klikając myszą przy naciśniętym klawiszu F6 (dotyczy modułu na Edge Chrome).


Okno Odczyt map WMS

Okno pojawia się po wstępnym wyborze zakresu mapy w module IMAP. W lewym panelu wpisane są współrzędne prostokąta pobrane z map Google oraz rodzaj układu współrzędnych.
Dostępny jest układ WGS84 stosowany na całym świecie oraz przez GoogleMaps oraz układ metryczny opracowany dla Polski o nazwie PUWG1992.

Po kliknięciu przycisku "Konwertuj" program przeliczy współrzędne z jednego układu na drugi.

U góry okna znajduje się lista serwerów WMS. Listę tę można rozbudować wpisując np. serwery lokalne po kliknięciu przycisku Zarządzaj. Po wybraniu serwera WMS z listy w lewym panelu wyświetlana jest lista warstw. Wstępnie wszystkie warstwy są włączone, użytkownik może złączyć dowolne warstwy z listy.

W celu zorientowania się w liście serwerów zwykle po prawej stronie nazwy serwera w nawiasie podane jest jego znaczenie np. "mapa sozologiczna" lub "mapa hydrologiczna".
Po wybraniu serwera, ustaleniu listy warstw, kliknięcie przycisku "Pobierz mapę" spowoduje załadowanie mapy do okna.

Wstępnie szerokość mapy ustalona jest na 800 pikseli. Użytkownik może zwiększyć szerokość mapy i jeśli chce uzyskać lepszą jakość wydruków map np. wykorzystywanych pod wykresem izolinii. Uwaga! Maksymalny rozmiar mapy jest ograniczony przez serwer WMS.

Jeśli mapa zostanie załadowana prawidłowo u góry okna zostanie wyświetlony rozmiar mapy w metrach oraz mnożnik liczby pikseli przypadających na metr, który będzie wykorzystywany w pakiecie "Operat".

Uwaga: w przypadku niektórych map, np. działek z Geoportalu, gdy szerokość mapy przekracza 2000 m zwracany jest komunikat błędu ‰PNG

U góry mapy znajdują się przyciski nawigacyjne umożliwiające zwiększenie skali mapy oraz przesunięcie mapy w dowolnym kierunku.
Po kliknięciu przycisku OK (wybierz) program przeniesie informacje o mapie do pakietu "Operat" a obraz mapy zostanie zachowany w bazie danych pakietu "Operat".

W przypadku, gdy serwer WMS nie uwzględnia układu WGS84 zalecana jest zmiana układu na PUWG1992.

Znaczenie przycisków:

Przycisk | Znaczenie
pobmap | powoduje załadowanie wybranej mapy
konwertuj | przelicza współrzędne geograficzne z układu WGS84 na PUGW1992 i odwrotnie
zarzadz | służy do zarządzania listą serwerów m.in do wpisywania nowych serwerów do listy
zamk | powoduje zamknięcie okna odczytu mapy
wyb | służy do przenoszenia informacji o wybranej mapie do pakietu "Operat"
min | powoduje zwiększenie skali mapy, z klawiatury Ctrl i "+"
plu | powoduje zmniejszenie skali mapy, z klawiatury Ctrl i "-"
kier | służy do przesuwania mapy w dowolnym kierunku. Przesuwać można także przy pomocy kursorów na klawiaturze numerycznej z włączonym NumLock, lub klawiszy funkcyjnych F5 - w lewo, F6 w prawo, F7 w górę, F8 w dół

Obok pola z listą rozwijalną serwerów WMS znajduje się przycisk dodopc, który służy do wyświetlenia dodatkowych opcji.

Znaczenie poszczególnych opcji.

Opcja | Znaczenie
Informacje o serwerze | Podaje nazwę i wersję serwera oraz wyświetla informacje o układach współrzędnych, warstwach i formatach graficznych obsługiwanych przez serwer
Kopiuj zapytanie | Kopiuje do schowka zapytanie wysłane do serwera WMS
Zapisane ustawienia | Podaje nazwę serwera ostatnio zatwierdzonego przyciskiem OK oraz wyświetla informacje o jego warstwach, rodzaju układu współrzędnych i współrzędnych prostokąta pobranego z map Google
Przywróć wybrane ustawienia | Umożliwia powrót do wybranych ustawień, zatwierdzonych ostatnio przyciskiem OK (dla danego projektu).
Parametry mapy do pliku | Służy do zapisywania wybranego serwera oraz wybranego zakresu współrzędnych i warstw jako pliku *.wmsparams
Parametry mapy z pliku | Służy do pobierania ustawień zapisanych wcześniej w pliku *.wmsparams
Pamięć podręczna | Otwiera okno konfiguracji pamięci podręcznej. W celu przyspieszenia otwierania map, obrazy są zapisywane w plikach tymczasowych. Można określić maksymalną liczbę plików oraz czas ich przechowywania.

Uwaga: mapy WMS można wykorzystywać zgodnie z regulaminem serwera WMS
Przykład: Geoportal Wrocław
Zobacz też dyskusję na temat korzystania z WMS: link1 link2


Okno Zarządzanie listą serwerów WMS

W oknie tym można dodawać, usuwać i porządkować listę serwerów WMS. Wstępnie wpisano kilkanaście serwerów oraz listę warstw przypisanych tym serwerom.
W celu dodania nowego serwera należy kliknąć przycisk "Dodaj", następnie wpisać adres serwera i podać jego właściwości. Właściwościami serwera są: lista warstw, obsługiwane formaty graficzne, obsługiwane układy współrzędnych.
Jeżeli przed kliknięciem przycisku dodaj będzie zaznaczona linia na liście, serwer zostanie dodany za tą linią, w przeciwnym wypadku na końcu listy.

Znaczenie przycisków:

Przycisk | Znaczenie
usu | powoduje usunięcie zaznaczonego serwera
zmien | otwiera okno "Właściwości serwera", w którym można pobrać listę warstw oraz listę formatów graficznych i układów współrzędnych, obsługiwanych przez serwer Zobacz: Okno Zmiana adresu stron i właściwości serwera WMS
aktu | powoduje odczyt właściwości wszystkich serwerów na liście. Uwaga! Jeżeli jakieś właściwości serwerów nie zostały jeszcze odczytane, zostaną one odczytane przy kliknięciu przycisku "OK".

Po prawej stronie listy serwerów znajdują się przyciski do porządkowania listy. Po zaznaczeniu listy serwera w panelu i kliknięciu przycisku up lub down można zmienić jego kolejność


Okno Zmiana adresu stron i właściwości serwera WMS

W oknie tym można wpisać nowy adres strony lub poprawić już istniejący dla zaznaczonego serwera WMS. Zaleca się wpisanie komentarza, który znajdzie się na liście serwerów (za nazwą serwera).
Kliknięcie przycisku pobwlasc, jeśli serwer jest czynny spowoduje pobranie listy warstw oraz obsługiwanych formatów graficznych i układów współrzędnych. Szczegółowe informacje można zobaczyć po kliknięciu przycisku info.
Kliknięcie przycisku xml odświeża pełne informacje o serwerze w bieżącej przeglądarce internetowej.
Kliknięcie przycisku ok spowoduje zapisanie właściwości serwera, jego adresu oraz listy warstw, innych właściwości.


Wyszukiwanie najbliższych stacji

Okno: Wyszukiwanie najbliższych stacji

Okno służy do wyszukiwania najbliższych stacji meteorologicznych, w określonym promieniu od wybranej miejscowości, na podstawie danych róż wiatrów zawartych w bazie programu.
Warunkiem wyszukiwania jest wpisanie współrzędnych geograficznych dla wszystkich stacji.

Współrzędne geograficzne można wpisać ręcznie lub zaznaczyć na mapie poprzez kliknięcie lewym klawiszem myszy przy wciśniętym klawiszu Ctrl. Wtedy zostaną wyświetlone informacje o współrzędnych geograficznych zaznaczonego punktu.
Można też wpisać nazwę miejscowości i kliknąć przycisk „Przejdź” obok.

Po kliknięciu przycisku „Przejdź” program zaznaczy punkt na mapie Google wraz z zaznaczonym promieniem wyszukiwania i znajdującymi się w jego zasięgu stacjami meteorologicznymi oraz uzupełni współrzędne geograficzne dla wybranej lokalizacji.
Po załadowaniu mapy zostanie wyświetlona informacja o skali mapy oraz będą dostępne przyciski i opcje znajdujące się w prawym panelu.

Mapę można przesuwać przez przeciąganie myszą oraz zmieniać jej powiększenie przyciskami plus i minus oraz kółkiem myszy.

Znaczenie poszczególnych przycisków znajdujących się w prawym panelu.

Przycisk | Znaczenie
OK | powoduje przejście do okna, w którym program utworzy różę z interpolacji
Anuluj | powoduje powoduje zamknięcie okna bez utworzenia róży
Pomoc | powoduje przejście do okna pomocy
Obraz do pliku | umożliwia eksport mapy do pliku graficznego w wybranym formacie


Pomoc do modułu GMap

 Licencje map

Google Maps: https://www.google.com/intl/pl/help/terms_maps/

Bing: https://www.microsoft.com/en-us/maps/licensing/options

Yandex: https://tech.yandex.com/maps/jsapi/doc/2.1/terms/index-docpage/


Pomoc do modułu IMap - początek współrzędnych

Okno: Początek układu współrzędnych

Okno pojawia się po wybraniu na mapie początku układu we współrzędnych geograficznych poprzez kliknięcie na mapie kombinacji klawiszy Ctrl+Alt+kliknięcie myszy lub F5+kliknięcie.

Domyślnie zaznaczony punkt ma współrzędne w sieci receptorów X=0 i Y=0.
Można do zaznaczonego punktu na mapie przypisać inne współrzędne np. X=1000,Y=1000 wpisując w polach odpowiednie wartości.

Współrzędne w sieci receptorów są współrzędnymi kartezjańskimi, w których początek układu jest określony przez użytkownika.
Taki sam układ współrzędnych jest stosowany w danych emitorów, siatek i rysunków, dlatego operację wyboru współrzędnych należy dokonać przed rozpoczęciem wprowadzania emitorów.

Przykład:

Ustawianie początku układu

Okno odczytu współrzędnych emitora

Wybór współrzędnych

Uwaga: Zmiana lokalizacji krzyżyka zmienia ustawienia geograficznego początku układu wykorzystywanego np. do eksportu wykresów do Google Earth.